mauvealert (3.8.0) stable; urgency=low
* HTML sanitizing only takes place if the text looks like HTML.
* Tests improved to couple processor and notifier buffers.
* Added authentication tests
* Removed remote auth tests in from the web interface tests.
* If no bytemark_auth_url is set, then no remote auth takes place.
* SSL peer cert validation now takes place by default.
* People/PeopleLists can now specify individualy notification times/frequencies
* Notification now uses #during/#every from the Person/PeopleList if nothing was specified
* Max acknowledgement time is now specified in the config
* Calendar interface improved.
* holiday_url no longer used -- replaced by notify_when_on_holiday!
* added notify_when_off_sick!
* Added ability for the calendar to be queried for a list of bank holdays.
* Added ability for Time to be given a list of bank holidays to check
against.
* PeopleLists can now be a Proc, allowing downloading of lists.
* Testing is much improved.
-- Patrick J Cherry Wed, 25 Apr 2012 17:16:56 +0100
mauvealert (3.7.8) stable; urgency=low
* Reduced the liklihood of race conditions during evaluation of during {}
clauses.
* Added cache to DuringRunner to reduce the number of times now? is
evaluated.
* Added a debug! option to notification_method clauses for easier, erm,
debugging.
* Alert#notify and AlertChanged#notify now make use of the notification
buffer make the disconnection betweeen the processing loop and
notifications happen sooner.
* Manpage typo sorted out.
-- Patrick J Cherry Wed, 18 Apr 2012 12:10:07 +0100
mauvealert (3.7.7) stable; urgency=low
* Javascript refreshes now happen every two minutes.
* Alert now tries to find just one matching AlertGroup, not all.
-- Patrick J Cherry Fri, 23 Mar 2012 15:02:53 +0000
mauvealert (3.7.6) stable; urgency=low
* Tweaked alert display to show the alert_group properly.
* Bumped Mauve::Version correctly.
-- Patrick J Cherry Thu, 22 Mar 2012 17:55:51 +0000
mauvealert (3.7.5) stable; urgency=low
* Added tests for web interface.
* Tidied up HTTP auth codes when auth fails.
* Further tweaks to alert_group caching, and source_list searches.
-- Patrick J Cherry Thu, 22 Mar 2012 17:44:58 +0000
mauvealert (3.7.4) stable; urgency=low
* Possible improvements in alert group caching, in an attempt to fix
slowness in the interface.
-- Patrick J Cherry Thu, 22 Mar 2012 10:06:07 +0000
mauvealert (3.7.3) stable; urgency=low
* Added destroy command to XMPP interface.
-- Patrick J Cherry Tue, 28 Feb 2012 14:35:17 +0000
mauvealert (3.7.2) stable; urgency=low
* Fixed Hash/Array confusions when merging conditions for notification.
-- Patrick J Cherry Thu, 02 Feb 2012 10:59:28 +0000
mauvealert (3.7.1) stable; urgency=low
* Fixed debian packaging to install everything.
-- Patrick J Cherry Mon, 30 Jan 2012 17:03:48 +0000
mauvealert (3.7.0) stable; urgency=low
* Bundled timer in with processor. What could go wrong..?
* Updated example.conf to work
* Added possibility of using postgres databases.
-- Patrick J Cherry Mon, 30 Jan 2012 12:31:06 +0000
mauvealert (3.6.3) stable; urgency=low
* Logs received at time in Processor
* Added lsb-base dependency
* Added test-task to init script
* Added include, include_file, and include_directory directives to
configuration.
-- Patrick J Cherry Fri, 06 Jan 2012 14:41:45 +0000
mauvealert (3.6.2) stable; urgency=low
* Tinkered with dependencies
-- Patrick J Cherry Mon, 07 Nov 2011 10:09:54 +0000
mauvealert (3.6.1) stable; urgency=low
* Fixed up alert ack parsing a bit.
-- Patrick J Cherry Mon, 07 Nov 2011 09:38:05 +0000
mauvealert (3.6.0) stable; urgency=low
* Changed ack command to split on spaces or commas or both
* Fixed initscripts to, erm, work when VERBOSE is not set
* Robustificated XMPP some more
* Moved all timestamps into epoch time from regular timestamps
-- Patrick J Cherry Fri, 04 Nov 2011 08:33:13 +0000
mauvealert (3.5.10) stable; urgency=low
* Fixed up Pop3Client class to work.
-- Patrick J Cherry Tue, 04 Oct 2011 15:29:22 +0100
mauvealert (3.5.9) stable; urgency=low
* Improve documentation in code
* Fix XMPP crash problem properly
* Fix XMPP acknowledge syntax for minutes, seconds, etc.
* Update template to remove colon between the subject and summary.
-- Patrick J Cherry Fri, 16 Sep 2011 13:20:51 +0100
mauvealert (3.5.8) stable; urgency=low
* Added rescue clause to XMPP connect
-- Patrick J Cherry Tue, 13 Sep 2011 07:56:38 +0100
mauvealert (3.5.7) stable; urgency=low
* Reminders are now unconditionally cleared when an alert is cleared.
-- Patrick J Cherry Mon, 12 Sep 2011 11:18:09 +0100
mauvealert (3.5.6) stable; urgency=low
* XMPP interface now saves note.
-- Patrick J Cherry Tue, 06 Sep 2011 15:56:01 +0100
mauvealert (3.5.5) stable; urgency=low
* Further updates to the suppression code. Should be much better now.
* XMPP interface fixed.
-- Patrick J Cherry Tue, 06 Sep 2011 15:30:11 +0100
mauvealert (3.5.4) stable; urgency=low
* Fixed up alert suppression to work better
* Also allow multiple suppression clauses in config
* Test for dual alerts when an alert unacknowledges.
-- Patrick J Cherry Tue, 06 Sep 2011 11:06:09 +0100
mauvealert (3.5.3) stable; urgency=low
* Fixed do_get timeout
* Added small cache for fetching external URIs.
-- Patrick J Cherry Wed, 31 Aug 2011 14:03:45 +0100
mauvealert (3.5.2) stable; urgency=low
* Added holiday checks
* Suppression now a bit less jumpy.
-- Patrick J Cherry Wed, 31 Aug 2011 13:07:50 +0100
mauvealert (3.5.1) stable; urgency=low
* Fixed XMPP interface to allow ack's from groupchat.
* Fixed XMPP interface to allow private chats to work.
-- Patrick J Cherry Wed, 24 Aug 2011 16:55:30 +0100
mauvealert (3.5.0) stable; urgency=low
* Added XMPP interface
-- Patrick J Cherry Wed, 24 Aug 2011 12:24:55 +0100
mauvealert (3.4.4) stable; urgency=low
* Added events calendar
-- Patrick J Cherry Tue, 23 Aug 2011 18:24:52 +0100
mauvealert (3.4.3) stable; urgency=low
* Fixed notification race-conditions.
* Reminders now get sent at the start of the next during period.
-- Patrick J Cherry Mon, 22 Aug 2011 11:58:28 +0100
mauvealert (3.4.2) stable; urgency=low
* Improved polling interval timing.
-- Patrick J Cherry Fri, 19 Aug 2011 16:56:33 +0100
mauvealert (3.4.1) stable; urgency=low
* Fixed note in alert acknowledgement box
* HTML now sanitized on save for Alert and History types
* Default thread interval now 0s for UDP server and Timer, 5s for everything
else
* Moar tests
-- Patrick J Cherry Fri, 19 Aug 2011 16:24:56 +0100
mauvealert (3.4.0) stable; urgency=low
* More thread monitoring
* Altered alert path for reminders
* Lengthened cookie lifetime
* Added an initial logger
* Can now have one history with multiple alerts
* Changed DateTime to Time everywhere
* Moar tests
-- Patrick J Cherry Wed, 17 Aug 2011 14:26:18 +0100
mauvealert (3.3.2) stable; urgency=low
* More pop3 tweaks
-- Patrick J Cherry Thu, 04 Aug 2011 17:18:13 +0100
mauvealert (3.3.1) stable; urgency=low
* Fixed bug in Pop3 server
-- Patrick J Cherry Thu, 04 Aug 2011 15:18:27 +0100
mauvealert (3.3.0) stable; urgency=low
* Added pop3 server
* Rejigged authentication
* Web interface improvements
-- Patrick J Cherry Thu, 04 Aug 2011 14:26:24 +0100
mauvealert (3.2.1) stable; urgency=low
* Fixed up alert_group matching.
-- Patrick J Cherry Fri, 22 Jul 2011 16:28:52 +0100
mauvealert (3.2.0) stable; urgency=low
* Re-organisation of config
* Added lots of tests.
-- Patrick J Cherry Fri, 22 Jul 2011 13:30:23 +0100
mauvealert (3.1.6) stable; urgency=low
* Added new heartbeat to remote mauve
* Added alert URL to messages.
-- Patrick J Cherry Wed, 20 Jul 2011 16:15:07 +0100
mauvealert (3.1.5) stable; urgency=low
* mauvesend can now specify an absolute time
-- Patrick J Cherry Wed, 20 Jul 2011 10:54:17 +0100
mauvealert (3.1.4) stable; urgency=low
* Fixed up recording of update_type for alerts
* Tidied up threading.
-- Patrick J Cherry Tue, 19 Jul 2011 22:44:30 +0100
mauvealert (3.1.3) stable; urgency=low
* Tidied up initscript
-- Patrick J Cherry Tue, 19 Jul 2011 17:59:01 +0100
mauvealert (3.1.2) stable; urgency=low
* Fixed up some gruesome spelling errors.
-- Patrick J Cherry Tue, 19 Jul 2011 16:42:19 +0100
mauvealert (3.1.1) stable; urgency=low
* Fixed mauveserver config file searching
* Updated dependencies for lenny (ugh)
-- Patrick J Cherry Tue, 19 Jul 2011 15:48:53 +0100
mauvealert (3.1.0) stable; urgency=low
* New version.
-- Patrick J Cherry Fri, 15 Jul 2011 14:03:15 +0100
mauvealert (3.0.6) stable; urgency=low
* Reminders to peple lists now work.
-- Patrick J Cherry Sun, 19 Jun 2011 21:52:16 +0100
mauvealert (3.0.5) stable; urgency=low
* Moar fiXXord.
-- Patrick J Cherry Fri, 17 Jun 2011 18:08:21 +0100
mauvealert (3.0.4) stable; urgency=low
* New release.
-- Patrick J Cherry Fri, 17 Jun 2011 08:57:55 +0100
mauvealert (3.0.3) stable; urgency=low
* Added get_all back to front-end
* Fixed up logging for more classes
* Catch empty notification lists
* Added console to server package
* Fixed document_root location
-- Patrick J Cherry Tue, 19 Apr 2011 11:31:10 +0100
mauvealert (3.0.2) stable; urgency=low
* Now checks for transmission time set to zero.
-- Patrick J Cherry Tue, 19 Apr 2011 10:27:13 +0100
mauvealert (3.0.1) stable; urgency=low
* Fixed up logging for the web interface
* Added better catch for validation errors
-- Patrick J Cherry Tue, 19 Apr 2011 10:18:44 +0100
mauvealert (3.0.0) stable; urgency=low
* New version.
-- Patrick J Cherry Wed, 13 Apr 2011 17:02:22 +0100
mauvealert (0.1-1) stable; urgency=low
* First release.
-- Patrick J Cherry Wed, 28 Oct 2009 10:34:17 +0000