aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPatrick J Cherry <patrick@bytemark.co.uk>2017-08-01 11:13:37 +0100
committerPatrick J Cherry <patrick@bytemark.co.uk>2017-08-01 11:13:37 +0100
commit89f7cb1762a865d72827a024559018efc247e185 (patch)
tree6db3c66f53d68c73ca7da923414fc38cf05813a8 /debian/rules
parent8a45a5152f953c5573bd18a3bd8b0785f3dea513 (diff)
Removed more cruft. Updated debian/rules to use the Makefile. Updated bundle
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 5 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index c43ea38..4097e2e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,20 +1,13 @@
#!/usr/bin/make -f
-
-# Ugh
-export GEM_HOME := $(shell pwd)/vendor/bundle
-export PATH := ${GEM_HOME}/bin:${PATH}
+
+export BUNDLER_FLAGS=--deployment --without='test development' --jobs=4
%:
dh $@ --with-systemd
-override_dh_auto_build:
- bundler install --deployment --without="test development" --jobs=4
- make
-
-override_dh_clean:
- dh_clean
- $(RM) -r vendor/
-
+#
+# We test separately in Gitlab.
+#
override_dh_auto_test:
echo "NOP"