aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPatrick J Cherry <patrick@bytemark.co.uk>2017-06-22 14:16:29 +0100
committerPatrick J Cherry <patrick@bytemark.co.uk>2017-06-22 14:16:29 +0100
commit929c689f3381ac71d80b2dda55a0ddf602efafe2 (patch)
tree8153d8f96b642265faac93962ec37bd7e6dfe862 /debian/rules
parent40533e34cca72fee719a9d84f6e07b13ca893b6e (diff)
Reconfigure server package to deploy to /srv/mauvealert
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 13 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5289f9d..04033e8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,17 @@
#!/usr/bin/make -f
+# Ugh
+export GEM_HOME := $(shell pwd)/vendor/bundle
+export PATH := ${GEM_HOME}/bin:${PATH}
+
%:
- dh $@ --with systemd
+ dh $@ --with-systemd
+
+override_dh_auto_build:
+ gem install bundler
+ bundler install --deployment --without="test development" --jobs=4
+
+override_dh_clean:
+ dh_clean
+ $(RM) -r vendor/