aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/mauvealert-server.postinst8
2 files changed, 9 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 798f058..a1c5cb1 100644
--- a/debian/control
+++ b/debian/control
@@ -43,6 +43,7 @@ Depends: mauvealert-common (>= 3.8.0),
libxmpp4r-ruby1.8,
${misc:Depends}
Suggests: mauvealert-client
+Recommends: liblocale-ruby1.8 | ruby-locale
Description: Mauve network alert system -- server
Mauve is a network alert system for system and network administrators. You can
use it to quickly set up ad-hoc monitoring for a variety of services, and to
diff --git a/debian/mauvealert-server.postinst b/debian/mauvealert-server.postinst
index 3d1c09a..967aa8d 100644
--- a/debian/mauvealert-server.postinst
+++ b/debian/mauvealert-server.postinst
@@ -17,4 +17,12 @@ for i in log lib ; do
chown -R $RUNASUSER:nogroup /var/$i/mauvealert
done
+#
+# Symlink jquery libraries in.
+#
+if [ -e /usr/share/javascript/jquery -a ! -e /usr/share/mauvealert/static/javascript/jquery ] ; then
+ ln -s /usr/share/javascript/jquery /usr/share/mauvealert/static/javascript/
+fi
+
+
#DEBHELPER#